Jump to content
SuperTramp

Creating Your mincoin.conf File. Adding Nodes For Better Connection.

Recommended Posts

In order for the MinCoin client to support more connections you might have to create an ini file in the %appdata%\mincoinfolder. To get to this folder click your start button (start->run for Windows XP) and type in %appdata%\mincoin

 

Now right click in the folder (not on a file or directory) and goto New->Text Document

 

Rename it to mincoin.conf

 

Now you should get this pop-up as you’re trying to change the extension of a .txt file to .conf. Click Yes.

ltcmining6.jpg

If you don’t get the above pop-up you’ll have to switch off “Hide extensions for known file types”. In Vista/Windows7 you can find this by pressing ALT once and then going to the Tools->Folder options menu. In Windows XP this menu should be visible without pressing ALT.

 

ltcmining9.jpg

After this, remove the .txt from the filename so the full name becomes mincoin.conf.

Now open mincoin.conf and insert this information:

 

addnode=54.218.157.95

 

addnode=208.115.109.156

 

Click "File" then "Save" then exit.

 

*Shouldn't really be a "need" for this ^ now with the latest client (mincoin-qt-v6.0.5.zip ) but I think we can keep this as a mini reference guide. ;)

Share this post


Link to post
Share on other sites

What are the mechanics behind this? What IP addresses are we connecting to, and how does it affect our computers? I am very interested in understanding this because if there is little drawback to it, I don't understand why every coin out there doesn't have millions of nodes!

Share this post


Link to post
Share on other sites

What are the mechanics behind this? What IP addresses are we connecting to, and how does it affect our computers? I am very interested in understanding this because if there is little drawback to it, I don't understand why every coin out there doesn't have millions of nodes!

The MinCoin client will automatically seek out nodes as it runs, but it's also possible to specify them in the .conf.  With a strong network for a coin, there will be many nodes that start getting connected to, but they must be open ports on the various firewalls for miners & coin clients.  If your port isn't open and forwarded to your computer, you won't show up to others as a node.

 

...that's how I understand it, anyway.

 

There are indeed many folks who will put a couple dozen nodes in their .conf file, which is totally valid. You just have to know a list that is consistent.  Many miners/clients shut off after a while, so that node disappears. There's no point having those nodes hardcoded, so you have to know what the real "permanent" nodes are.  Many pools will provide a more permanent node, for instance.

 

There's not much reason to specify addnodes unless you're having trouble getting connections.  Three or four connections will do the trick.

Share this post


Link to post
Share on other sites

I would like to reiterate Joseph's questions, I too am curious to understand the situation better.

 

What are the mechanics behind this? What IP addresses are we connecting to, and how does it affect our computers? I am very interested in understanding this because if there is little drawback to it, I don't understand why every coin out there doesn't have millions of nodes!

 

 

How many nodes are needed for a strong network?

 

 

 

Also, what's particularly special about the two addresses given by SuperTramp? Are they some pool nodes that are more stable or always-on? By IP lookup, I see that they are on opposite coasts of the U.S., does that help increase your "node reach" in the network?

 

addnode=54.218.157.95

 

addnode=208.115.109.156

 

Share this post


Link to post
Share on other sites

The total number of nodes is important, of course, but it really only takes maybe 2-3 permanent, trusted nodes to maintain the whole network, as far as I know.  As more open-ported miners/clients stay running, people will start to get lists with a lot of nodes, but many of them will "expire" as computers shut down or ports close, etc.

 

The ones noted by SuperTramp are nodes set up to be permanent, so you don't have to worry about them getting turned off on the fly just because some miner decides to turn off his computer, for instance.

 

Specifying trusted/stable nodes is just a way to force looking at those IP addresses for nodes.  The client will start finding other nodes as it keeps running, if they exist.  

 

One benefit of a bunch of nodes and client connections is in downloading the blockchain, I think.  The more, the faster.  (I'm pretty sure on that, anyway.)

Share this post


Link to post
Share on other sites

The total number of nodes is important, of course, but it really only takes maybe 2-3 permanent, trusted nodes to maintain the whole network, as far as I know.  As more open-ported miners/clients stay running, people will start to get lists with a lot of nodes, but many of them will "expire" as computers shut down or ports close, etc.

 

The ones noted by SuperTramp are nodes set up to be permanent, so you don't have to worry about them getting turned off on the fly just because some miner decides to turn off his computer, for instance.

 

Specifying trusted/stable nodes is just a way to force looking at those IP addresses for nodes.  The client will start finding other nodes as it keeps running, if they exist.  

 

One benefit of a bunch of nodes and client connections is in downloading the blockchain, I think.  The more, the faster.  (I'm pretty sure on that, anyway.)

 

Just to add to this ^

I run a node 24/7 with ports opened and forwarded on my router and I currently have 63 connections. I also had my node IP hard-coded into the latest MNC GUI build for added

network stability/connectivity. There were also a couple other node IPs hard-coded into the last build (mincoin-gui-client-qt-v605/) and this is why most people are getting 4-5 connections now on their MNC client upon start-up :)

Share this post


Link to post
Share on other sites

i get stuck at %53.35 +\- have added the extra nodes tried both clients (6.0.5 and v0.6.5.0-g498f5d1-beta).... still can't get past that point.... turned the firewall off and on in windows... (which i hate, wish there was a precompiled ubuntu 64bit bins).

 

getting frustrated, i am raping the p2pool for mnc, but can't get any transactions, lol

 

oh yea and am paying a 0.01 transaction fee in the wallet to "speed up" transactions.....

 

i understand it works like bittorrent, sooooooooooo i should be in here yelling "PLZ SEED!" LMAO

 

 

 

 

 

(rededited for stuff)

 

%53.36 (just for the time stamps)

Edited by Blackross

Share this post


Link to post
Share on other sites

Hmm.. I'm not sure what the trouble is for you. I just recently reinstalled a machine (Windows 7) and put the new Mincoin wallet on it. I decided to just download the blockchain instead of restore a backup.  I had some trouble at first getting more than a couple connections, but I ended up opening the port on my router's firewall and now I've got 62 connections and chain was updated quickly.

 

I could do more tests to see what closing the port will do, but I've been thinking of this issue as roughly "solved" since I keep having success.

 

Transactions do move pretty slow when the network hash is down, due to the 1 minute block times as well as the general speed.  However, you should be able to get the chain without too much trouble right now, considering all the active nodes.

 

BTW, my .conf file has no addnode entries at all. I just opened the port on the router (port 9334).

Share this post


Link to post
Share on other sites

"I decided to just download the blockchain instead of restore a backup.  "

hmmm, how do i do that /\

as for port 9334 thats easy....

 

 

Well the other funny thing is in the settings of the wallet "use pnp port mapping" is checked... and i can't uncheck it. lol

Share this post


Link to post
Share on other sites

 

"I decided to just download the blockchain instead of restore a backup.  "

 

hmmm, how do i do that /\

 

I mean that I installed the wallet & did a clean install/download by letting it run until it gets the whole blockchain. I had a backup of the whole MinCoin folder, which I could have just copied over the blockchain folders instead of re-downloading, but I decided to let it get a fresh copy. There's really no reason to do this most of the time. I just copied over my wallet.dat file, which is what has all the balance/transaction information.  Be sure to back that up if you go changing things up and deleting stuff to re-download.  wallet.dat is the most important file in there...the only important file, really.

 

You should start by trying to open port and then move to other bits if needed.  RE your "pnp portmapping" thing.. I'm not sure what's up with that, but it's not needed.  You add port in your .conf file and then open your router firewall port to point to the computer with the wallet on the network.

 

There's info on these forums for mining and help with the mincoin.conf file.  I'll refer you to search to find that, rather than retyping, but let me know if you have troubles.

Share this post


Link to post
Share on other sites

yeah, last night i found the linux version of the mincoin client installed and did the same, just copied the appdata to the .mincoin folder (without the larger files, just the wallet stuff) and its still sat there after a couple of hours at 53.53%.... this morning before work, i killed it, no change, refired it up on the windws system.

 

working overtime this month sooo it sat here undisturbed all day, came home to the same, 53.53% i have 20 connections now, and 2 transactions.... but hasn't moved beyond that magic number. i'll leave it sit till tomorrow, sunday are the only days off this month, sooo ill have pleanty of time to muck around with things.

 

ports are still forwarded, though the router... hmmm.

 

the port setting is the rpc port swtich? right

(i really don't want to kill it since i have 20 people on the thing)

 

the windows box is moving right along

[2013-12-07 18:21:43] accepted: 124655/125557 (99.28%), 2.85 khash/s (yay!!!)

the *nix box..... hmmm working on it.

 

OK, its crunching through blocks 254236 out of 474638 (blocktime Sat Dec 7 21:13:49 2013) that seems to be where my lag is, its moving slowly... sooo tomorrow i should have more progress, lol, right now its like watching my gradmother ride a tricycle up a steep hill in the mud.... its working just not the fastest.

Share this post


Link to post
Share on other sites

LOL, still moving slow.

 

well.... going to leave it run all week, ports are forwarded, have 26 connections, just still crunching through that %53... well now at %53.70, lol

 

block 255120 out of 475092

 

soo i work 5a to 5p mon-sat (overtime month at the re-engineering facility), i'll glance at the thread every so often, oh yea btw, still can't uncheck the pnp port setting in the option dialog even though i specified the port in the conf (which is obvious with the clients i have now).

 

i'll watch for a new version :)

 

thanks for the help!

Share this post


Link to post
Share on other sites

LOL, still moving slow.

 

well.... going to leave it run all week, ports are forwarded, have 26 connections, just still crunching through that %53... well now at %53.70, lol

 

block 255120 out of 475092

 

soo i work 5a to 5p mon-sat (overtime month at the re-engineering facility), i'll glance at the thread every so often, oh yea btw, still can't uncheck the pnp port setting in the option dialog even though i specified the port in the conf (which is obvious with the clients i have now).

 

i'll watch for a new version :)

 

thanks for the help!

 

What you are seeing is actually just a cosmetic/graphical error. The MinCoin blockchain is not into the 400K block range, that is the litecoin blockchain. For some reason some of the alt coin clients that were forked off the litecoin code occasionally stil try to connect to the litecoin blockchain. But, like I say, this is just a cosmetic/graphical error.

Current MinCoin blockchain is at 256,755 (at the time of me writing this response).

 

Also, using the latest MNC client there really is no longer a need to make this Config file to add nodes as you should be getting 3-5 connections within a minute or two of the client starting up. ;)

Share this post


Link to post
Share on other sites

Hello,

 

    Please share recent nodes which are fully connected.  Unable to find a sync with the network using previously published addnode entries.

 

Best Regards,

-Chicago

Share this post


Link to post
Share on other sites

Hello,

 

    Please share recent nodes which are fully connected.  Unable to find a sync with the network using previously published addnode entries.

 

Best Regards,

-Chicago

 

Currently at 13 active connections on my client. Good job getting the seed nodes back in order!

Share this post


Link to post
Share on other sites

Hello,

 

    Thanks!  So here is a report from a few moments ago from the bitcoin-seeder fork crawling our chain.

    The most stable full nodes are the following and I plan to update this list over time when the landscape changes or when those most stable nodes cannot be reached.

 

    That being said, the DNS Seed should be working for everybody now and does see several hundred queries per week.

 

        139.162.128.92

        45.77.6.168

        104.130.211.223

        [2001:4801:7827:102:be76:4eff:fe10:7c6f]

        178.49.192.210

        174.104.142.99

        [2a01:7e01::f03c:91ff:fe67:dba]

 

    The only particular ordering applied to the above list is the order in which they were checked for availability.

 

Best Regards,

-Chicago

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use.